Azure.Storage v4.4.0 or greater is required

Blog post is updated – 2021-04-06

Since my solution, in this original blog post, was very weak and did not solve the problem for all users, I have now updated this blog post.

Eric Markson sums the problem very well in his blog post "DXP Deployment API – Azure.Storage Error Fix"

So, while we wait for an update in the EpiCloud PowerShell module, we have added the same fix as Eric did for all tasks in the Epinova DXP extension for Azure DevOps. So now you will not be forced with your own fix. It is built into all the task already.

You will get a warning now when you run the tasks from Epinova DXP extension. But these can be ignored. And as soon as the new version with EpiCloud PowerShell module has been released with a fix, we will remove this hotfix.

2_warnings.jpg

2_warnings_log.jpg

Warning text:

Because the Az modules have all the capabilities of AzureRM modules and more, we will retire the AzureRM modules on 29 February 2024. Learn more about the migration to Az: http://aka.ms/azpsmigrate

 

Sorry if anyone have got into trouble because of my original blog post!

Read more